2011年10月29日土曜日

Windows7が起動中に止まる 続き2

先日から発生しているWindows7(64bit)が起動途中で止まる件の続き。

--- 前記事
■いつまで続くのでしょうか…: Windows7 起動しない!?
http://oojima33.blogspot.com/2011/10/windows7.html
■いつまで続くのでしょうか…: Windows7が起動中に止まる 続き
http://oojima33.blogspot.com/2011/10/windows7_28.html


また起動しない。 ちなみにやろうかと考えていたビデオカード、サウンドカードのドライバー更新は、まだやっていない。 そうだ、この前採取設定したブートログを見てみようと思ったが、、、考えてみると次起動成功するとその前の失敗した時のものは上書きされて消えてしまうのでは?

ということで、もう一つのOS、過去に別HDDにインストール済みのVista君(HomePremium 32bit)を起動させて、Vistaの方から7のドライブ見てブートログを退避しておこうと考えた。 さて、Vistaを久々起動と。。。 起動しねー!! OS選択画面でVistaを選んですぐ真っ黒の画面に。(´ε`;)ウーン… もしかして7と同じ症状? ただ、7と違って、こちらはキーボードでCTRL+ALT+DELETEが反応して再起動ができる。


7でダメ、そしてVistaでダメとなると、OSの問題ではなくハードということか?


とりあえずケースを開けてみてみた。 おやっ? SATAのケーブルが若干斜めになってるぞ。 ちゃんとはめ直してみる。 その後、Vistaは正常起動。

んでもって、Vistaの方から、問題の7のブートログを見てみるが、結局は参考にならなかった。 起動完了していないので、ログが作成されていないのだ。 ログファイル(ntbtlog.txtファイル)はあるけど、更新日時が以前のまま。 こいつは随時書きこむわけではなく、起動完了して書き換わるようだ。 な、わけで起動途中での状態、起動がうまくいかなった時の内容は取れない。。。



ただし、先ほどSATAケーブルのはめ直したせいか、7も通常通り起動できた。

なお、問題のSATAケーブルが本当にVistaのHDDにつながっているかがわかれば、スッキリするのだが、あいにくと同じHDDが2つあって、どちらがVista用か把握できていないんですね。。。 …以前RAID0をやるのに同じのを買ったのだ。 ちなみに今はRAIDしていない。

ま、これでしばらく様子をみて、その後も7が問題なく起動できたなら結果的にSATAケーブルのゆるみが問題だったと確定してよいかと。 とりあえず、数回シャットダウン→起動した範囲では今のところ100%正常起動できてます。


--- 追記:2011.11.20 ---
SATAケーブルをはめ直した後は、起動しないという現象は発生しなくなった。 毎日とはいかないが、週に3~4日はPCを使っていて、全くもって正常に動作している。

結論:今回の原因は、SATAケーブルがゆるんでいたためHDDを正常に認識できず、はめ直すことで解決。

ところで、SATAケーブルにはラッチ付き/無し があるが、今まで自分的にはラッチ無しがいいかなぁと思っていた。 最初はラッチ付きの方が抜けにくいのでいいだろう と思っていたが、いざ外すとなると大変な場合がある。 M/B上のSATAが集中していて狭いところでは、ラッチを抑えて抜くのがね。 考えてみるとデスクトップPCだから基本的に動かすわけでもないし、ラッチ無しでも抜けることはないだろうから、抜き差ししやすい分、やっぱりラッチ無しでいいだろうと考えるようになった。

でも、今回のようなことがあって、どっちがいいか分からなくなった。。。 PCパーツの構成を変更するのに意図的にSATAケーブルを抜き差しする機会は多くはないのだから、その時多少面倒でも我慢して、その後は抜ける心配のないラッチ付きの方がいいのではないかと。 でも、、、ラッチ付きで抜けにくくて強引にやって破損するとか可能性もなくはないしな、、、 (´ε`;)ウーン…

2 件のコメント:

Nakamura Naomitsu さんのコメント...

こんにちは。
私は、ノートPCのHDDをSSDに取り替え、HDDを光学ドライブベイにアダプタを使って設置しました。
すると、起動中画面で固まってしまいます。あきらめモードで30分ほったらかしにしておいたら、ログイン画面になっていました。

Vista以降、起動時には接続デバイスのチェックを行うようになったそうです。

結論は違いますが、起動ドライブは正常でも、他のドライブチェックで引っかかり、時間をとっていたとういう点では同じ現象ではないでしょうか。

解決策ですが、msconfig.exe のブート
タグで、起動種類(ふつうは1つ)して、OSブート情報 のチェックボックスをオンにします。これで再起動。
このとき、ブートログをオンしてもかまいません。

私が行ったのはここまで。
ブートログだけだとどうなるかは実施していません。あしからず。

3番目の人 さんのコメント...

Nakamura Naomitsu さん、コメントありがとうございます。最近めっきりブログをチェックしておらず、コメントに気がついてませんでした。。。

「OSブート情報」ですか。全く分かっていなかったのでぐぐってみました。セーフモードで起動させた時に、どばぁーって出てくるやつですかね。(実際に自分では試していないんですが)

おかげさまで、通常起動の時にも出せることを初めて知りました。どうもです。

幸い今は自分の方は現象が治まっていますので、今後何かトラブルが起きた時には試してみようと思います。セーフモードで起動できても、通常だとNGなんてトラブルを巷では少なからずあるようですし、そんな時にはかなり有効な情報になりますね。